Crawlbase Status Page

DNS resolver slowdown

Resolved
Website Dashboard Leads API
Degraded Performance

Issue in DNS resolver tables has made some parts of the website become slow for some clients.
The problem is now solved and service is back to normal.